Not able to upload images

When I go to upload my batch of 769+ .PNG images of 764KB-5MB each (roughly 2.44GB total) the web loader seems to read in some of the file names, but no images are produced in the frame to indicate they’ve been uploaded (they were not uploaded). The only images that I was able to upload were all 325KB-2.7MB each (90.4MB total). I have attempted to resolve this by clearing my cookies and cache, restarting my computer, trying again on a different browser (Safari), and even attempted to make a new project. I have also attempted to upload 1 image at a time to no avail on both browsers.

  • Project Type: Object Detection
  • Operating System & Browser: Ventura 13.6 | Chrome Version 117.0.5938.132 (Official Build) (x86_64) | --------- Also tried --------- | Safari Version 16.6 (18615.
  • Project Universe Link or Workspace/Project ID: License Plate OCR Object Detection Dataset by MS Thesis CEC 700

I’m sorry to hear that you’re having trouble uploading your images to Roboflow. Based on the information provided in the extracts, there are a few things you could try:

  1. Check the format of your images: Roboflow supports JPG, PNG, and BMP images. Make sure your images are in one of these formats. source

  2. Use the API for uploading: If you’re having trouble with the web interface, you could try using the Roboflow API to upload your images. Here’s a sample code snippet for uploading images to an existing project using the Python SDK:

from roboflow import Roboflow
rf = Roboflow(api_key="YOUR_PRIVATE_API_KEY")
project = rf.workspace("WORKSPACE_NAME").project("YOUR_PROJECT_ID")


  1. Check your internet connection: Make sure you have a stable internet connection while uploading the images.

If none of these solutions work, it might be a good idea to reach out to Roboflow’s support team for further assistance.

Hi! I’m Roboflow’s AI powered bot. This is an automated response powered using AI with knowledge from our docs, blog, knowledge base, and previous forum responses. If you find this to be a helpful answer, please mark it as the solution using the checkbox icon below. If this doesn’t solve your issue, please follow up with what you’ve tried/why, and the community will continue to chime in as usual.