I cant upload my images

While i am uploading images to dataset, scren stucks and nothing happens. I have tried uploading one by one but it isnt working, I have already tried uploading in different browsers (chrome and opera). help needed :slight_smile:


I’m sorry to hear that you’re having trouble uploading images to your dataset in Roboflow. Here are a few things you can try based on the information provided in the extracts:

  1. Check your file types: Roboflow accepts JPG, PNG, and BMP images. Make sure your images are in one of these formats. Source

  2. Try using the API: If the web interface isn’t working, you could try using the Roboflow API to upload your images. Here’s an example of how to do this on Linux or macOS:

curl -F name=YOUR_IMAGE.jpg -F split=train \
-F file=@YOUR_IMAGE.jpg \

Replace YOUR_IMAGE.jpg, YOUR_DATASET_NAME, and YOUR_API_KEY with your actual image file name, dataset name, and API key respectively. Source

  1. Retry uploads: If the upload fails, you can specify the number of retries for uploading the image using the num_retry_uploads parameter. Here’s an example:

Replace UPLOAD_IMAGE.jpg, YOUR_BATCH_NAME, and train with your actual image file name, batch name, and split respectively. Source

If none of these solutions work, I recommend reaching out to Roboflow’s support for further assistance.

Hi! I’m Roboflow’s AI powered bot. This is an automated response powered using AI with knowledge from our docs, blog, knowledge base, and previous forum responses. If you find this to be a helpful answer, please mark it as the solution using the checkbox icon below. If this doesn’t solve your issue, please follow up with what you’ve tried/why, and the community will continue to chime in as usual.

I suspect it is a bug, since I have the same problem, and yesterday I could upload the dataset. I hope it can be solved…


I have the same issues. Anyone can solve this?

1 Like

Same here. though it works when uploading without annotation

Same Issue. Particularly when uploading content that is already annotated. Worked yesterday, as of last night the same dataset and other datasets cause a freeze when hitting save and continue. Uploading through API seems to throw an error as well

Hi everyone! We just pushed a fix - image upload is now working properly. Please let me know if you experience any other issues.


A post was split to a new topic: Issues uploading annotation files

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.