I upload 936 images, but only 120 get save into roboflow

As the title said, only 120 get upload into roboflow and I don’t know why, and I think that it’s not reach the limit yet.

Based on the information provided in the extracts, there are no specific details about a limit of 120 images for uploading into Roboflow. However, there are several factors that could potentially limit the number of images you can upload:

  1. Duplicate Images: Roboflow utilizes similarity matching to filter out duplicate or nearly identical images from your dataset. If an image’s content is the exact same, it is only counted towards your usage once. So, if you’re trying to upload duplicate images, they might not be counted. source

  2. Plan Limits: Depending on the plan you’re on, there might be limits to the number of images you can upload. For example, the free plan has certain limitations. source

  3. File Size or Format Issues: If your images are too large or in an unsupported format, they might fail to upload.

If you’re still having trouble, I would recommend reaching out to Roboflow’s support or checking their help pages for more specific guidance.

Hi! I’m Roboflow’s AI powered bot. This is an automated response powered using AI with knowledge from our docs, blog, knowledge base, and previous forum responses. If you find this to be a helpful answer, please mark it as the solution using the checkbox icon below. If this doesn’t solve your issue, please follow up with what you’ve tried/why, and the community will continue to chime in as usual.

Hi @Peeranat_Thongsakul

I think @Lenny gave a good answer here. The main reasons, beyond a bug, would be if there were extremely similar or duplicate images, if you hit a limit for your plan, or if there were issues uploading.

If you did experience issues, you should see an error message pop up. If you didn’t, could you share if there are any errors in the developer tools console?

Hi @stellasphere

I also have the same problem, but I am not hitting the plan limit (I’m uploading <900 PNG images). I do not have duplicates, but I was wondering about the file size issues. Could 764KB-5MB per image (roughly 2.44GB total) be too much for the web loader to handle? I posted an issue on the forum, but have had no success in the other alternative solutions provided by @Lenny.

Hi @Isaac_Kay

Are you experiencing the issue where only a smaller portion of the images are uploaded? I don’t believe that the individual image size would cause those issues.

Could the images be similar enough that they are detected as duplicates?

Hi @leo, thank you for getting back to me. None of the images from my iphone images dataset are being uploaded. They are all converted to .png file types.

I also tried using the Google Collab code snippets in order to utilize the API to upload the folder of aforementioned PNG images from my Google Drive, but to no avail.

I’m not sure how “similar” they would need to be. There’s 778 images of various license plates that I took, but they’re not all around the same distance or angle plus there’s different lighting for most (a couple hundred are inside a public garage).

(I also wanted to show you what I’m seeing from the error call - and yes my private API key is loaded (it’s just out of frame). I did this for the “Upload Folder of Images” section as well with the same results.)

Hi again @leo.

So I solved it!

Just in case someone else comes across this issue, let me explain:

If you’re uploading images via your iPhone and transferring them to your Mac (like I did) you’ll notice they are downloaded as .HEIF files. In order to make them usable for most software, you’ll need to convert them into PNG, JPEG, etc., file formats (nothing you didn’t already know).

Here’s where I went wrong: I renamed all the file types from .HEIF to .PNG (.png doesn’t matter if it’s capitalized or not) and called it a day, since the “Kind” descriptor in the Finder folder deceptively identified all the images as “PNG image”.

I troubleshooted by downloading a singular image from my Google Drive that I had previously uploaded from the same folder and opened it up in Preview. I used the “Show Inspector” tool under Tools and what do you know…“Document type: HEIF Image”.

Here’s how you solve the issue quickly. You use a built-in command-line tool called sips to convert the image format (in my case I had .png endings for my filenames even though they were indeed .HEIF document types, so I used this):
for i in *.png; do sips -s format png "$i" --out "${i%.*}.png"; done

If you have .HEIF file types/names (or any other image type) use this:
for i in *.HEIF; do sips -s format png "$i" --out "${i%.*}.png"; done

Here’s the final product:

One last note, if you need to rotate your images (like I did since after I successfully uploaded my images to Roboflow they were rotated 90 degrees CCW) you can also use sips for this and rotate them back 90 degrees CW:
for i in *.png; do sips -r 90 "$i"; done

Hi @Isaac_Kay

I’m glad that you were able to solve this issue and we appreciate you posting your solution to help others experiencing the same issue in the future!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.