Cannot upload image through Roboflow API

Dear all,
I found that I’m not able to upload image (and or) annotation files through Roboflow API.
To elaborate on the issue, I did see a progress bar running when I used either “drag”, “select folder”, or “select files” approaches, but nothing was uploaded. There was warning if I tried uploading massive amount of images or upload annotation files that did not have a human-readable format.
Several things that I’ve tried:
0. Try using different projects and empty projects. → not working.

  1. Shortening image name and or only upload one per test → not working.
  2. Only upload images but not corresponding annotation files → not working.
  3. Uploading the data through python script (Upload API - Roboflow)-> not working. Neither the combining 0~2 approaches using script worked.
    I’ve validated that the file formats are all compatible. I’ve done uploading files before and never had I experienced anything like this.
    Even though I am using a public free plan, I’ve checked and am convinced that I am not running out of storage or usage.
    Any suggestion would be much appreciated.

Best regards,

Just want to get a heads up if anyone else also faced the same issue or potential solution?

Hi Jack - to confirm, was this upload error occurring first when using the Roboflow app (the user interface), or was it first triggering when attempting programmatic upload via API, or the CLI?

I see you’ve had the error a few times, but looking to confirm what the first upload method you tried was.

Additionally, what annotation format do you have for the images, and where does the dataset originate from, in terms of where you exported from, and did you label them somewhere else first?

Finally - how many images were uploading in total?

Dear Mohamed,
Thanks for the reply. I was using the Roboflow user interface “selecting folder to upload method” when I first encountered the issue. I selected a folder from my computer, which had 3300 pairs of .jpg images and .txt annotation files.

As for the questions regarding data type, it was a YOLOv5 project with 640*640 resolution .jpg images and .txt annotations. Since I’m working on transfer learning right now, the annotation data were generated through yolov5 detection (which was the reason I’m getting the missing label map warning). I’ve pretty much done everything on roboflow except generating new annotation using yolov5 on my computer, and I’ve never encountered any relative issue until my latest request.
As for the last question, I tried uploading (i) single .jpg image (ii) 3300 .jpg images (iii) 3300 pairs of .jpg and .txt. All failed.
Maybe I’m secretly running out of available credits? From my account, I should still have 4756 source images space available.

Thanks for taking the time.
Best regards,

Let’s try these 2 options, and if they both fail, please let me know:

  1. Try creating a labelmap (data.yaml) file to include in your upload, and then select the entire folder (with all images, labels, and the labelmap file) and drop them into the Roboflow UI:
  • be sure to orient your images, label files and labelmap like how I have in my screenshot below, especially if you have a pre-set train/valid/test split. If the images aren’t split in train/valid/test, you can just include a folder of images and labels to drag and drop with the labelmap (data.yaml)
  1. Upload the folder with images, annotations, and the labelmap file, using the Roboflow CLI: Command Line Interface - Roboflow

Dear Mohamed,
Thanks for reaching out.
Yes, the first method worked out perfectly!
I’ll test the second approach if necessary in the near future.

Best regards,

1 Like

@Jack_LI awesome!

1 Like

No, you’re awesome!

A post was split to a new topic: Issues uploading a converted .tif to the API