My work was stuck at the last step of data upload

  • **Project Type: upload failed
  • **Operating System & Browser: Google
  • **Project Universe Link or Workspace/Project ID:ds2_dense_oriented_train

I successfully uploaded the image data (more than 300 images, with a resolution of 1960*1400) and the YOLO version of the .txt annotation file, but when saving the upload, the progress stalled at the last bit.

I browsed related issues, so I tried clearing all traces of the browser, or changing to other browsers. I even changed two computers and many networks, but they all failed in the same way.

I would like to ask if the same problem has happened before. I need some help and guidance. Thank you.

My screenshot showed that three pictures were not uploaded successfully, so I tried to delete these three pictures and annotations, but the same problem still occurred.

Hey @lava_finalL

Sorry to hear about your experiences with our platform. Could you share the following so I can try replicating the issue?

  • Does the issue always occur on the same three images?
  • Are there any error messages in the developer console? (how to)
  • Are you able/willing to share the images you are trying to upload? If yes, please upload them here if you are okay sharing or use the private message feature (then let me know you’ve done so here)

Thank you for your prompt reply. I later tried to save the image first and then upload the annotation, and found that the problem occurred in the annotation. They are the Bounding Box format of YOLOv8 format. I should strictly follow the writing method of this format. As shown in the picture, there will be a total of 136 classes, so the serial numbers range from 0 to 135. The progress bar interface disappeared quickly after uploading, as if I had done nothing.

I also tried the rotatable calibration box annotation, as shown in the picture. I should also follow its writing format.

Hey @lava_finalL

Thank you for the extra information, but in order to help you resolve this issue, I would like to be able to recreate it.

From the initial image you sent, it looks like the annotation files were successfully processed and associated with each image and therefore what’s happening is a upload issue, potentially related to the images you are uploading.

Could you please provide me with the info from my previous reply?

Additionally, if you believe this to be an annotation issue, could you also provide the annotation file and the data.yaml file in text format for your annotations?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.