Images and labels refuse to upload

When trying to upload images to my dataset it attempts to upload the files but the progress bar of the first file doesn’t move and I get the “It seems to be taking a long time” message!

I’ve tried both on my desktop and laptop and the same thing happens, regardless of which browser I use

What error messages/warning are appearing in your devtools/console?

What browsers are you using? What versions?

OS name and version?

Classification or Object detection project?

This sounds like a network firewall blocking access to some of the cloud servers we use.

You (or your IT department) will need to URLs that need to allow-list the following URLs (although it will depend on your organization’s particular rules which of these are blocked in the first place):

*.roboflow.com
*.googleapis.com

These additional urls are typically not blocked but could also cause an issue if they were:

1 Like

I tried after adding these to my Bitdefender Exceptions list but it still wouldn’t upload. I even tried uninstalling bitdefender, so without a firewall it still wouldnt upload D:

@Kelly I get the error popup:

"It’s been 30 seconds and it looks like there hasn’t been any progress on the upload.

It could be that your Internet connection is really slow, or your upload requests are being blocked (e.g. by a firewall, ad-blocker, browser extension, anti-virus, or other network settings).

For additional support please see https://docs.roboflow.com/support."

Tried both on Firefox and Microsoft Edge, Windows 10

and its an object detection project

Are there other upstream firewalls (Eg on a corporate network) that could be blocking it vs bitdefender on your local machine? Maybe an overly sensitive ad blocker or privacy extension?

I have never seen this error except when one of the above listed services is blocked.

Hi everyone thanks for all your help! I found out it is my university internet, for some unknown reason to me it blocks the ability to upload images to roboflow… it’s never blocked me from doing so on any other website/platform, god knows why uploading (and only uploading) to Roboflow is being flagged by their firewall…

figured out I could upload if I tether to my phones 4G

Interesting; which University? We can try to connect with their IT team and see why they’re blocking Google Cloud services.

Loughborough University, United Kingdom

1 Like