Error for training yolov5 model on colab

github: :warning: WARNING: code is out of date by 1121 commits. Use ‘git pull’ to update or ‘git clone GitHub - ultralytics/yolov5: YOLOv5 🚀 in PyTorch > ONNX > CoreML > TFLite’ to download latest.
Traceback (most recent call last):
File “”, line 497, in, opt.cfg, opt.hyp = check_file(, check_file(opt.cfg), check_file(opt.hyp) # check files
File “/content/yolov5/utils/”, line 124, in check_file
assert len(files) == 1, “Multiple files match ‘%s’, specify exact path: %s” % (file, files) # assert unique
AssertionError: Multiple files match ‘…/data.yaml’, specify exact path: [‘./weights/…/data.yaml’, ‘./data/…/data.yaml’, ‘./models/…/data.yaml’, ‘./train/…/data.yaml’, ‘./utils/…/data.yaml’, ‘./pycache/…/data.yaml’]
CPU times: user 26.7 ms, sys: 8.77 ms, total: 35.4 ms
Wall time: 2.83 s

Hi @Fibi_Annan_Metiki, can you provide some more context behind the error?

If you can send a screenshot of the cell that gave you the error, as well as the cell in which you uploaded the images with the export code, it will help with debugging this.

This is the process you’d typically use for beginning the notebook, and starting the training step:

Hi Mohamed I shared my screenshot image.

ok I solved the problem thanks

Hi @Fibi_Annan_Metiki you’re saying you did find the error?

It looked like the path to the data.yaml file needed to be an absolute file path, rather than a relative file path. Was that the error?

Hi Mohamed. yes , I modified the path and it works

1 Like

@Fibi_Annan_Metiki could you please explain what do you mean by absolute file path? i have the same error and can not solve

@Ayesha you can just replace into the file data.yaml …/train/images by content/train/images
the same for valid and test folder.

1 Like

@Ayesha but I think for the last version of github repo of yolo It works even without replacing it