Wrong Ultralytics version when uploading model to Roboflow workspace

Hi. I am currently training object detection model YOLOv10-L on my spectrogram dataset on Google Colab. When I deploy my model to Roboflow, i’m getting the error down here. I have tried running pip install ultralytics==8.0.196 in the beginning but it didn’t work.

The error on my workspace is " Model Upload Failed This model upload failed. A failure usually occurs because of an older, incompatible model version or possibly a new type we don’t currently have support for.

Please try again with a new version and re-upload the model. If the error persists, reach out and we will be happy to help debug."

Is there any way to resolve this issue?

Hey @JasonNg231

As it suggests in the error message, occasionally different versions of the ultralytics package can cause trouble with the model upload process. Please install the suggested version and try again. Let us know if the issues persist after this.

Hi leo.
I tried installing different version of Ultralytics but for some reason, it’s still giving the same errror. I ran the installation in the beginning of the code too.

Actually when I install the required version before importing the model, I get this error down here.

Hey @JasonNg231

We generally don’t provide support for the Ultralytics package since it isn’t maintained by us, but from a quick look, it looks like you are trying to import YOLOv10 from ultralytics, not YOLO (which I believe is the proper module).