Model Upload continues for 4 days

Hello Guys,

I have uploaded the images, created dataset and annotations with roboflow. After that, i trained model with google colab according to example " How to Train YOLOv8 Object Detection on a Custom Dataset" without problem. When i tried to upload the model with command :

project.version(dataset.version).deploy(model_type="yolov8", model_path=f"{HOME}/runs/detect/train/")
An error occured when getting the model upload URL: This version already has a trained model. Please generate and train a new version in order to upload model to Roboflow.

I got the error and when i checked the Versions page of my project :

I got


Your uploaded model will be ready to use soon!

and deploy page :

Model upload is processing.

This page will automatically update when it's ready to use.

since Monday. Is there something wrong or model upload process still continues ?

Best Regard

Our development team pushed a fix that should resolve this.

You’ll need to regenerate the version, train, and upload weights to it.

Or, if you have saved the weights, you won’t have to retrain, but you’ll still need to generate a new untrained version to upload the weights to.

Hello Mohammed,

Thank you for your answer. I followed the step you mentioned and successfully create and deploy model.

Best Regards

Ultralytics YOLOv8.0.49 :rocket: Python-3.8.10 torch-1.13.1+cu116 CUDA:0 (NVIDIA A100-SXM4-40GB, 40514MiB)
Setup complete :white_check_mark: (12 CPUs, 83.5 GB RAM, 28.0/166.8 GB disk)

Hey there, I seem to be having a similar error on Colab. The model deployment is taking forever on roboflow. I uploaded models > 24hrs ago and the website has not received them. I do not get the URL error.

When I run

project.version(PROJECT_VERSION).deploy(model_type=“yolov8”, model_path=f"{HOME}/runs/segment/train/")

I get…

Dependency ultralytics<=8.0.20 is required but found version=8.0.49, to fix: pip install ultralytics<=8.0.20
View the status of your deployment at: Sign in to Roboflow
Share your model with the world at:

Downgrading causes there to be weird errors with the data loader during training and does not fix my problem.

I’ve generated new versions twice and not had any upload success. I’ve had the same issue for two seperate projects.

Hi @willem_weertman - we don’t yet accept model weights upload for YOLOv8 instance segmentation, only object detection.

In terms of the product roadmap, we’re exploring adding the other models for weights upload. Be on the lookout for updates as to when this could happen.

That would be good, I guess I overlooked that in the documentation. Bummer. It seems to me that if it is not aloud there should be an error message that reads out so users are left thinking it is roboflow having unreliable servers or someother non-sense.

I’m curious as to where the deploy code was found, but the model types it works for wasn’t?

Can you let me know where you found that weights upload was possible with the specific deploy function?

I want to make sure it’s explicitly written what it works for, as well. The training notebook shouldn’t have had any references to weights upload organically, for instance segmentation, at least.