How can I delete a deployed segmentation model that is in limbo state?

I tried to deploy my segmentation model via:

project.version('3').deploy(model_type="yolov5", model_path=f"{HOME}/yolov5/runs/train-seg/{DATASET}/")

Since I don’t know what model_type should be (docs?), I also tried

project.version('2').deploy(model_type="yolov5-instance-seg", model_path=f"{HOME}/yolov5/runs/train-seg/{DATASET}/")

After 12 hours, it still says:
Model upload is processing.
This page will automatically update when it’s ready to use.

Hi @mh_rocket2

At this time, there’s no way to detach/remove a model from a version. That said, you can always generate a new version and delete the old one.

As for what to put in the model_type field, check out our docs on uploading weights to Roboflow.

The following model types are supported:

  • yolov5, yolov5-seg

  • yolov7, yolov7-seg

  • yolov8, yolov8-seg, yolov8-cls

That is helpful to know, unfortunately it still doesn’t work completely.

By deleting the versions, I was able to “delete” my limbo models.
I then created a new version of the dataset (quite some workaround, because the version before was fine, just the model associated to this version wasn’t behaving)

When I run
project.version(new_version).deploy(model_type="yolov5-seg", model_path=f"{HOME}/yolov5/runs/train-seg/{DATASET}/")

I get a new model, that is now in limbo for 9hours.
(Instead, I would like to get an error message, debug it, and re-try)

Just as with the limbo model before the model pages (app.roboflow and universe.roboflow) say:
Model upload is processing.
This page will automatically update when it’s ready to use.

I now deployed everything custom myself on my own servers

Hi @mh_rocket2

Sorry for the delayed update. We looked into why this failed and it seems to be an issue with the model file.

We’ve seen issues where people uploaded from an incorrect model path or applied post-processing to the model.

If you are still experiencing issues, could you please share the notebook you are using to train?