Bug: Deploy failure on uploaded model weights

I trained a YOLOv8 segmentation model (yolov8s-seg) and uploaded it to Roboflow using the Python API version.deploy("yolov8-seg", ".../weights", "best.pt"). The Python code runs fine without any errors and I made sure the the version of installed ultralytics (8.0.196) was supported by Roboflow.

When I go the the Model page of my roboflow project I can see that roboflow actually recognizes the model and know it is a yolov8s model. However, there are no numbers on any metrics (mAP, Precision, Recall) (they are just blank).

At the same time when Roboflow tries to load this model to run on an image it gives out an error window saying:

Oops something went wrong, there might be issues with the model

I checked the console in the browser and found that a POST request for inference failed with a status code of 500 server error, which seems to be the main cause of the issue:

I have tried training another model but the same error came up. Would appreciate any help for solving this issue! Thanks!

I figure out the cause now:
I uploaded the segmentation model to a object detection project which is not compatible (Strangly the object detection still accepts segmentation on labelling).

I created a new instance segmentation project and now it is working :sunny:

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.