Can't see my teammates

Hi. I’m trying to distribute labeling work across my friends, but for some reason I don’t see them in “Assign Images for Annotation” tab. Howerver, they are shown in the Workspace->Members tab

And this is “assign images” tab:

When I press “Invite Teammate” and type their email again, I get the message “The number of additional collaborators allowed on this workspace is 3.” meaning that I already have them here.

Hi @Sorrow321

Sorry to hear you’re having issues. We looked into it and we weren’t able to reproduce this issue. Are all of your team members experiencing this issue?

Could you try the following steps to see if the issue is resolved:

  • Try logging out and logging back in
  • Try clearing the local storage, cache and cookies off your browser
  • Try logging into Roboflow from an Incognito window

I tried

  1. incognito window
  2. other browser

But still can’t see anyone in the list

It sounds like it might either be a database sync delay since they could’nt reproduce the same result, are you by chance using a VPN? sometimes that can mess with this sort of thing, and would make sense if the same result happened on incognito. Or maybe it could be a technical glitch. Have you confirmed from your teammates that they do not have access, or can they see their roles in the workshop?

EDIT: These docs are also really useful for this particular issue: Role-Based Access Control - Roboflow Docs

1 Like

They are both “Admins”. Could this be the problem? Can I only assign to “Labelers” group?


Nice job @Sorrow321 , I think that’s the solution. Being that you all are admins, assigning tasks to one another makes little sense given the same position in the project. Changing their role from Admin to Labler should make the workspace work as intended. But, I can’t say for sure. However, I plugged your problem into Roboflow’s AI built on their documentation and general data, and given this situation, it agrees with us.

"Yes, you are correct. According to the information provided in the extracts, only users assigned the role of “Labeler” can be assigned images for annotation. As per the documentation, when you invite a team member to a Workspace, you can choose between Admin (full access) or Labeler (Job only access). Labelers will only be able to see and annotate images assigned to them.

If you want your team members to annotate images, you should assign them the role of “Labeler”. Admins have full access but are not listed in the “Assign Images for Annotation” tab because their primary role is not to annotate images but to manage the workspace.

If you want to change their role, you might need to re-invite them as “Labelers”. However, please note that according to the blog post, Labelers are only able to access the images you assign to them and utilize the labeling tools for annotation of those images. All other information is hidden from Labelers to ensure privacy and security for your data."

I hope this solves it!

1 Like

Hi @Sorrow321

Thanks to @Alejandro_Bermudez for the response!

We looked into this issue and it was a bug that should be fixed as of now.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.