Trained model runs with error on mobile with Lens Studio


I’m trying to scope out the possibilities for using Roboflow in combination with Lens Studio but i’m running into some issues. At first i assumed i did something wrong training my model, however the same issues is there in the Lens Studio example project from this livestream of Roboflow and Snap:
Livestream video:
Template download:

The project runs in Lens Studio but when i deploy to a mobile device i get the following error in Snapchat:

When i select the ML model in Lens Studio i can see the Compability Table which has a bunch of things not supported. Layers like Concat / Constant / Permuta / Reshape / Split.

I’m using Lens Studio version 4.55 on a Windows PC. On the models i trained with Roboflow myself i get the same error on mobile device. If anyone has an idea of how to fix this that would be much appreciated.



I’m sorry to hear that you’re encountering issues with using Roboflow in combination with Lens Studio. However, based on the information extracts provided, I don’t have specific details about the issues you’re facing or the steps you’ve taken so far.

Here’s a general guide on how to deploy a Roboflow model to Lens Studio based on the information from the blog posts:

  1. Train your model in Roboflow. If you’re new to Roboflow, you can follow the Getting Started with Roboflow guide.

  2. Once your model is trained, you can deploy it to SnapML. In Roboflow, click on “Deploy” in the sidebar, then scroll down until you see the “Use with Snap Lens Studio” box. Click “Export to Lens Studio”. This will download the Roboflow Lens Studio template and your model weights (source).

  3. Install Lens Studio if you haven’t already. You can download it from the Snap AR website.

  4. Open the Roboflow Lens Studio template you downloaded earlier. You can configure your model for use in the application using the MLController component (source).

If you’re still encountering issues, it would be helpful to know more about the specific problems you’re facing. Are there any error messages? At what step does the issue occur? This information can help in providing a more targeted solution.

Hi! I’m Roboflow’s AI powered bot. This is an automated response powered using AI with knowledge from our docs, blog, and forum. If this solves your issue, please mark it as the solution using the checkbox icon. If this doesn’t solve your issue, please follow up with what you’ve tried/why, and the community will continue to chime in as usual.

Hi there,

I did those exact 4 steps you described and i indeed got an error when deployed to a mobile device. The error can be seen in the image in the original post. The same error happened when i downloaded the example lens studio project supplied by Roboflow in the link mentioned above.

Hi @LeonKleinBreteler, I’ve never seen this error before. I asked the Snap team & they requested that you repost this on their forum here for the SnapML support team to look into. If you let me know once you do that I’ll make sure to flag it for them.

It’d also be helpful to include more info about the mobile device (eg devicve and OS versions and Snapchat version).

Hey Brad,

i reposted on the SnapML forums here:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.