Model Upload Error (version already has a trained model) and MODEL UPLOAD REQUEST RECEIVED never updating

When trying to upload a model trained in Google Colab using Google Chrome (following a roboflow example video), I get the error “An error occured when getting the model upload URL: This version already has a trained model. Please generate and train a new version in order to upload model to Roboflow.” This has occurred multiple times (in different detection projects) after I trained a model and tried to upload for the first time.

Additionally, a model never actually gets uploaded to roboflow. Both project just show " MODEL UPLOAD REQUEST RECEIVED - PROCESSING…" and stay that way several days after training a model in Google Colab.

What tutorial / model did you train and attempt to upload weights for?

I’d like to try the same process to check for bugs.

I followed this video exactly (YOLOv8: How to Train for Object Detection on a Custom Dataset - YouTube).

I apologize as I misspoke and I did use my own custom dataset. Sometimes when I generate a new model version (or if I train in Colab with a previously generated version) and train it within Colab I can upload without an issue, and sometimes I can not. The issue is intermittent but I still always get the same errors (uploads requested in roboflow never receiving the model and google colab stating the version already exists)

Unfortunately there have been some hiccups with the new weights upload release.

However, we do appreciate your feedback, as you’re helping us to ensure this feature is robust to the point these bugs are wiped out.

For the YOLOv8 weights upload, there was another person having an issue earlier this week, but after uploading trained weights to a newly generated version when we pushed a fix this week, they informed me the weights upload worked without issue.

  • I believe it will work now if you generate a new version to train, and then upload the weights