Generating new dataset version leave images empty

This category is for question related to accounts on

Please share the following so we may better assist you:

  1. Project type: Object detection
  2. MacOS 13.1 & Chrome 109.0.5414.119

Did you make any changes or updates to the project between now and back in December? (new images, images removed, changed project names, deleted versions?)

This will be helpful for looking into this, as I’m not sure what occurred off first look.

I did, i have added new images in annotate tab, also was annotating a lot and then added them to dataset, i didnt change project name. I remember i did change name of latests version of dataset only. Now i am not able to create new version of dataset its empty, i tried to delete those empty images versions and create new ones, but no luck

@Mohamed can you provide more info on status of this issue or who should i contact so i can at least retrieve my data?

@Juraj_Budai - I found the issue for your dataset. The annotation characters did not get parsed correctly.

The box labels are expected to be strings led with a letter (and we’ve recently added support for labels to be led by numbers, if you choose).

In your case, I assume you uploaded a dataset that contained non-English characters for the labels, or you added non-English characters for the labels within Roboflow.


Modify Classes will be required to remap the characters in your generated version so it comes out successfully:

@Mohamed I have used the same type of labeling for my classes previously and i have 6 versions of datasets that are working and were succesfully created. I didnt upload any classes, everything added to current dataset is made in roboflow. And also i have used same pattern for newly added images “\uUNICODE {^_RL CHARACTER}” . So you also implemented non-English character recently? Because only non-English character are curly bracers {} according to this: English character table | Character Table.

@Mohamed Last 3 versions of Datasets i tried to generate are decent tests according to what you suggested:

  • v22 Remapped to replace {} - ()

  • v23 Remapped to remove labels with {}

  • v24 Drop all, leave 1 remapped from \u2609 - u2609

And it didnt work for any of them. :cold_sweat:

@Juraj_Budai - I’ve just created a detailed bug report outlining:

  1. the project history since December
  2. the tests you ran that still resulted in failed generated images
  3. generated images tests I ran that also failed (and any associated error messages)

This will help us to get a fix for you ASAP.

@Mohamed Thanks a lot, i hope you can fix it ASAP. Send <3 to devs.

@Mohamed I am sure you are working on fix, but can you give me some estimation, or some work-around on how to export data. I am working on my final thesis and i am kinda in a hurry.

Unfortunately I don’t have a concrete estimate, but I’ll ask them.

When is the thesis due?

Thesis till April, but i have to have dataset ready until 15-20th March. I am doing more annotations in my workspace for few more days, but after i finish them i will really need those data.

@Juraj_Budai ok, I believe it will be completed (the fix) before the end of this week. I’m ensuring that I check in on the status so I can get back to you right away.

I have your email as well to stay in touch.

1 Like

@Mohamed Hello can you give me some update please? Or we can move our conversation to email.

I will send you an email now

@Mohamed I want to remind myself. I did send you followup email to our previous conversation.

@Mohamed I am having an issue where when generating new dataset the images have completely different and incorrect labels from the actual dataset, even though I have not applied any processing. What is going on??

@bakiasib is there potentially EXIF data?

Have you generated any versions with Auto-Orient? That may resolve it - if it does not, let me know: When Should I Auto-Orient My Images?