Error downloading dataset on colab

Please share the following so we may better assist you:

The following error is occurring :

/usr/local/lib/python3.7/dist-packages/roboflow/core/ in init(self, version_dict, type, api_key, name, version, model_format, local)
62 version_without_workspace,
—> 63 local=local,
64 )
65 else:

TypeError: init() got an unexpected keyword argument ‘local’

  1. Screen shot of your error

  2. Copy/Paste of your code

!pip install roboflow

from roboflow import Roboflow

rf = Roboflow(api_key=“PRIVATE_API_KEY”)

project = rf.workspace(“workspacename”).project(“projectname”)

dataset = project.version(1).download(“multiclass”)

  1. What you’ve tried so far to debug

This error is happening for the latest version of roboflow. I tried 0.2.11 and it was working fine with it .Tried different accounts for the dataset, same issue exists everywhere for the latest version of roboflow.

Hi @Nikhil_Priyadarsh thank you for reporting this.

I made a bug report for the team, and we were able to track down the issue and fix it. The newest version of the roboflow package (0.2.14) will work without issue.

Here is sample code to get it installed, and export your dataset:

pip install -U roboflow

from roboflow import Roboflow
rf = Roboflow(api_key="PRIVATE_API_KEY")
project = rf.workspace("WORKSPACE_ID").project("PROJECT_ID")
dataset = project.version(1).download("multiclass")

Hi @Mohamed, the latest version of roboflow works. Thanks for resolving the bug.

1 Like