CSV annotation files don't work

i have a dataset to do object detection, then i will convert it into coco format using roboflow

I’m new to Roboflow and trying to import a bunch of images and a CSV annotation file.

The image was uploaded successfully, but when I uploaded the annotated CSV nothing happened and the image was not annotated

Root Folder
├── testing_images
│   ├── image1.jpg
│   ├── image2.jpg
│   └── ...
├── training_images
│   ├── image10.jpg
│   ├── image11.jpg
│   └── ...
└── bounding_boxes.csv

My CSV file contains the following structure:

one CSV annotation file contains annotation data for 100 images

When I upload data and select the root folder, the images are added but they are not annotated using the info on the CSV file.



Based on the information provided, it seems like you’re trying to upload a CSV file with annotations for your images in Roboflow. However, it’s important to note that the CSV file format you’re using might not be compatible with Roboflow’s expected format.

Roboflow supports the Open Images data format, where you receive a large CSV file containing all of the annotations in the entire dataset along with a class map. You also receive .txt files for annotations for each image. Roboflow recommends using the .txt files for annotations (source).

If you’re having trouble with the CSV file, you might want to consider converting your annotations into a format that Roboflow supports. You can do this by creating a free account with Roboflow and using their data conversion tool (source).

If your annotations have errors, Roboflow will alert you. For example, if some of the annotations improperly extend beyond the frame of an image, Roboflow intelligently crops the edge of the annotation to line up with the edge of the image and drops erroneous annotations that lie fully outside the image frame (source).

If you’re still having trouble, I recommend checking out Roboflow’s documentation or reaching out to their support for further assistance.

Hi! I’m Roboflow’s AI powered bot. This is an automated response powered using AI with knowledge from our docs, blog, and forum. If this solves your issue, please mark it as the solution using the checkbox icon. If this doesn’t solve your issue, please follow up with what you’ve tried/why, and the community will continue to chime in as usual.

I have converted my annotations, from .csv to .xml or .txt, but when I upload the annotation file it still doesn’t read, is this a problem with the data structure in it?

Hey @Habib

I see that @Lenny inferred a Open Images format, could you should share the specific dataset format that you are trying to upload? A CSV is a file format, and we support the dataset formats listed on our formats page.

sure, where do I send it?

sorry, you can get the dataset at https://drive.google.com/open?id=14xE5ldzlM3W7gFORaWAVYnEiT1ycr3DA&usp=drive_copy

Hey @Habib

Sorry for the miscommunication, I meant: Could you tell me the structure or format type that the annotation files are in? (For example, the Google Cloud AutoML CSV format or the OpenImages CSV format)

The formats page links to all the annotation formats that we support imports for. If your CSV isn’t in that format, you might have to convert to a supported format.

Also, I couldn’t open the Google Drive link since I didn’t have access.

I think the annotation is RetinaNet CSV format based on what I read in the paper’s publication

Sorry about Gdrive Access, I’ve updated it

Hey @Habib

That format isn’t currently supported for import into Roboflow. You will need to convert it to one of our supported formats before you upload the annotation files.

OK, thanks for the help and answers, I think I will not use that data set again, because it takes up too much time

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.