Class not shown after labeling

Hi, i am having an issue that after i label all the images and train the model with roboflow, it doesn’t show any class names when the model detects something, it only shows “-” as the class name.

I labeled the images in Korean, so it’s not alphabet letters.
Could it possibly make this problem? And if so is there any way i can rename all the labels at the same time?

I tried modifying classes from preprocessing phase, but it only shows 4 classes, which are classes in Korean also, from 31 classes.

It would be really helpful if someone can answer this.

Thank you

Hi @민주_맹

I think the Korean labels might be the issue, but I’d like to clarify where it is showing “-” for you.

  • Is it only in the detection results?
  • Does it show up when you’re looking at the annotations on an image?
    chrome_rUNgHXeRn8 chrome_SKMU2L6jpZ chrome_u6O9AbEhTN
  • Does it show up when you’re using the Modify Classes augmentation?

Hi! Thank you for the reply!

I actually solved the problem by changing all the labels into English.

So what i got was among 32 classes when I go to Modify Classes it only showed 4 class names and after training it didn’t show any of 32 classes.

I guess we can’t use roboflow other than alphabets