How do i remap or merge classes in the annotator tool?

Probably not a bug, but couldn’t find a good category. Im new to the platform, moved from another platform and imported my work. It added my classes as 0,1,2,3,4 which is not user friendly. I’ve mapped them on generate, so thats part fine. But I need them remapped on the actual annotation I don’t want 0,1,2,3,4,5, I want the actual labels. Now I have the actual labels, and 0,1,2,3,4,5, so it’s gotten out of control. It’s harder to annotate because the list is so long, and I’m not even using the numbers. Do I need to export the mapped files, and start a completely new project an import everything to clean it up? I was going to assign some things to some annotators and get some help, but I cant until I get this worked it, it’s to messy.

It seems like you’re having trouble with class labels in your dataset. Roboflow provides a feature called Class Label Remapping and Omission that can help you manage your class labels more efficiently.

Here’s how you can remap and omit class labels in Roboflow:

  1. Navigate to your dataset’s page within the Roboflow platform.
  2. Proceed to generate a new version by selecting Generate New Dataset and click to Add Preprocessing Step.
  3. Choose Modify Classes in the preprocessing options.
  4. You will then be presented with a screen where you can rename your classes and exclude any class annotations that are not needed.

This feature allows you to quickly adjust the scope of your detector and fix any labeling errors. After you apply these changes and finish your other preprocessing and augmentation settings, the dataset version will export with these new class label settings.

If you’re still seeing the old labels, it might be due to some common errors that require a label map, such as class names showing as integers or class labels not being recognized.

If you’re still having trouble, you might want to consider starting a new project and importing your data again. However, before you do that, I would recommend trying the class label remapping feature first.

For more information, you can refer to these sources:

Hi! I’m Roboflow’s AI powered bot. This is an automated response powered using AI with knowledge from our docs, blog, knowledge base, and previous forum responses. If you find this to be a helpful answer, please mark it as the solution using the checkbox icon below.

Hi @hylytrapp

Sorry to hear you’re having issues. What format did you import your data in? Were the class names different on your previously used platform?

You could also try what @Lenny suggested and use the remap preprocessing tool:

Thanks you, came from Labelbox and imported. I am using the remap tool but it only exports that I can find, doesnt fix the problem of all the classes being in the annotating tool when they dont need to be. Seems I need to remap, export, start a new project, and import, is that the only way to clean it up?
All my balances are off, I cant tell what is what unless I keep a notebook beside me with it all mapped out.

You can see what I mean in this graphic

Hi @hylytrapp

Yes, exporting with no preprocessing or augmentations and creating a new project would be the easiest way to solve the issues of your incorrect class labels. I hope that fixes your issues and you can continue with your project.

Thank you, I am going to give it a try.

1 Like