Unable to modify class id

Please share the following so we may better assist you:

  1. Project type;Object detection
  2. Browser: Chrome
    I need to re-train my model using my own dataset which should be in TF record format. For this, I need to modify the class id as per my choice as I want to integrate the results with another model. In short, I need non-overlapping id’s. I did the following:
  3. I annotated data using roboflow.
  4. Downloaded in darknet format and ran a script to modify the first column of the .txt annotation file which is the class is. I changed it from 1 to 90, 2 to 91 and so on.
  5. I uploaded to roboflow to access it from colab for training. After uploading the id’s are renumbered to 1,2,3 instead of 90,91 and also the class names are changed to 90,91 instead. I tried coco instead of darknet format and the same happens. Also, the classes are automatically arranged in alphabetical order. I’m sure I modified the class id’s and not the class names
  6. I want the class id’s to not change after uploading and I dont want them to be re-ordered in alphabetical order.

Hi @Swetha_Sarma, our annotation file format exports are standardized to have label ID’s included alphabetically at this time.

Thank you for the suggestion. Perhaps we can include a future setting to select an ordering of classes?

Additionally, you can load/merge the datasets together into Roboflow to export together, too (to avoid wrangling them yourself):