New roboflow project upload gives me "object" instead of class type

This category is for question related to accounts on

Please share the following so we may better assist you:

  1. Project type (Object detection)
  2. firefox/macos

** Reproduce steps **

  1. Create new roboflow object detection project
  2. Upload files from this zip file
  3. You will see the bbox classes are read just fine, but the classes for the polygons are all read as “object”. I used to use the exact same script to generate data and upload it for the other projects I’ve done and it worked fine, so not sure what happened now.

It looks like roboflow is reading the shapes, but missing out on the class names.

You can see the problem here: Sign in to Roboflow. there are ~60 “objects” in one picture with the right shape, but no class.

Hi @vshesh, what annotation format is the JSON file supposed to be?

This is the sample COCO JSON format: COCO JSON Annotation Format

Select “Example” on that page to view the full example file

Hey @Mohamed ,

It’s in VGG format, this one: VGG Image Annotator JSON Annotation Format

Ok @vshesh I’m taking a look now. Additionally, I saw you said “I ran this script before…” - is there a reason you’re still annotating elsewhere rather than on Roboflow?

You have negative values for size on all of the images. The size cannot be negative.

annotations - This is synthetic data, so it’s easy for me to generate annotations programmatically rather than doing it by hand online!

size - in the past -1 size has not been an issue for these files when uploading to roboflow, but I can try to replace with zero or height * width. Also the data did upload, and some of the data (the rects) were processed correctly, so how would changing this solve that issue?
edit: I tried with size: 1 for the same file and got the same issue when uploading. I didn’t upload but when I clicked on the image it showed the object class instead of the class listed in the json file.

The part of the upload that didn’t seem to work is that the type in the region_attributes wasn’t detected for polygons. Everything else seems to have worked correctly.
In the console I can see this log entry: