Inquiry Regarding Incorrect Bounding Box Coordinates Export in RoBoFlow (YOLOv8)

Describe your question/issue here! (delete this when you post)

  • **Project Type: Object detection **
  • Operating System & Browser: Windows / Google Chrome
  • Project Universe Link or Workspace/Project ID: bullet

Hello [RoBoFlow Support Team],

I hope this message finds you well. I am currently using RoBoFlow for annotation tasks, and I have encountered an issue during the export process. When exporting the annotated dataset, the bounding box coordinates are not in the expected format of <class> <center_x> <center_y> <width> <height>. Instead, the exported format appears to be <class> <x> <y> <width> <height><y> <x> <height> <width>.

I have reviewed the export settings, but it seems that the coordinates are not exported in the correct format. I would appreciate your assistance in resolving this matter. Could you please provide guidance on how to adjust the export settings to ensure that the bounding box coordinates are exported in the expected format for YOLOv8, specifically in the form of <class> <center_x> <center_y> <width> <height>?

Thank you for your attention to this matter, and I look forward to your prompt assistance.

It seems like you’ve started to ask a question about an object detection project in Roboflow, but your question is incomplete. Could you please provide more details about your issue? Including the following information will help us assist you better:

  • A detailed description of your issue or question.
  • The operating system and browser you are using.
  • Any error messages you’re seeing, preferably with screenshots.
  • Your Universe project link or workspace/project ID, if applicable.

Once we have this information, we’ll be better equipped to help you resolve your issue.

Hi! I’m Roboflow’s AI powered bot. This is an automated response powered using AI with knowledge from our docs, blog, and forum. If this solves your issue, please mark it as the solution using the checkbox icon. If this doesn’t solve your issue, please follow up with what you’ve tried/why, and the community will continue to chime in as usual.

Is it right to do it later?

When creating a new version, I didn’t make any configurations. I didn’t set up Preprocessing or Augmentation.

And why are there so many errors while writing? Errors like error 422 and “An error occurred: Sorry, new users can only put one embedded media item in a post,” etc. are disrupting the smooth question-asking experience.

Additionally, I used only bounding boxes without utilizing polygons.

Hi there, we had a bug last week with yolov8 exports, can you please try generating a new dataset version and see if that fixes the export format.

I haven’t done the format yet, but it was solved by exporting to YOLOv7

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.