Dataset Split ratio changed automatically after creating a new version bug

Project Type:

I am working on an object detection model using Yolov8 I created a dataset using Roboflow for 3 classes the total images in the dataset is 1,222 with roughly 400 images per class I selected 70:20:10 for train, test and val in Train/Test Split

For pre-processing I selected image size to be 256X256 with fit reflect edges in option

I selected 7 augmentation steps

Lastly I selected 3x for maximum version size

After the dataset was created when I checked the details the dataset split ratio changed automatically now it is 88:8:4 I tried again and it again showed the same result I don’t know why it is happening I am suspecting it is because of augmentation as it increased the number of images the program didn’t take into account the increased images and did not adjust the train:val:test ratio thus creating a skewed train/val ratio

Here’s the before and after dataset creation

Operating System & Browser:

Operating System - windows 10 version 22H2
Browser - Brave browser version Version 1.65.114 Chromium: 124.0.6367.60 (Official Build) (64-bit)

Project Universe Link or Workspace/Project ID:

Project ID - yolo-samiran

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.