Bug: Label assist on deployed YOLOv8 instance segmentation model

I have some issues on deploying my custom YOLOv8 instance segmentation model to a new project to generate annotations for the new dataset:

When I tried the model on a new image in Roboflow editor it doesn’t generate anything no matter how I change the confidence and overlap values. The console output from developer tools is:

Uncaught (in promise) Error: Error in transpose: rank of input 1 must match length of perm 0,2,1.
    at Object.h (util_base.js:139:15)
    at transpose_ (transpose.js:52:5)
    at Module.transpose__op (operation.js:44:28)
    at e.<anonymous> (index.ts:184:25)
    at roboflow.js:2:1249588
    at Object.next (roboflow.js:2:1249693)
    at i (roboflow.js:2:1248407)

I also try public models like MS COCO on label assist and it is working fine which can generate annotations. When I use my custom YOLOv8 model it doesn’t even show the message box ‘X annotations applied’.

Hi @jche774

Could you share your project and workspace ID or Universe link so that we can help sort out this issue for you?

Does this issue occur with other Universe models? (You can try Universe models by clicking on the star icon on their page and selecting it in Label Assist)

Hi Thanks for helping!

I tried other Universe models on yolov8 segmentation and they worked fine surprisingly. But my model actually deploys fine and can show the segments normally on Deploy page shown below:

My model can be found here:

workspace: uoa-x5mvo
project: 2023p4p13

Hi @jche774

Did you happen to upload your model through the .deploy function in our Python package? The issue might stem from something wrong with the uploaded model.

Could you share the notebook you used to train the model?

Hi @leo

Yes I used version.deploy() to upload my model to Roboflow. Do you mind giving me your email address? I didn’t keep the exact version of that particular trained model but I can share the model weights and result with you.

Hi @jche774

I don’t think sending over model weights is necessary, especially if I don’t know the model type since I can’t do much without that.

Would you like to try again and if so share the notebook you tried it with?

The three things to check when uploading model weights is:

  • Make sure you write in the correct model type
  • Make sure you have a supported version of Ultralytics installed (which shouldn’t be a problem if you used one of our notebooks)
  • Do not apply any postprocessing to the model weights as that could mess things up

@leo hi I have same issue
Error in transpose: rank of input 1 must match length of perm 0,2,1.
with label assist

Its instance segmentation model

@leo Model is working fine Sign in to Roboflow, but not inferencing in Label Assist

Project id is teeth-number-prediction in my workspace called vazgen-hakobjanyan