Roboflow Train 3.0 Object Detection Failed

Project type - Object detection
The operating system & browser - windows 11 / Google chrome
Tried image sizes - 640x640 , 512x512, 400x400 but all failed.
Some of run but after 15 epoch , it failed again. and gives below error code
for 9751 images


Training Failed

This training job did not complete successfully. This can happen for a few reasons but often means that the chosen model dimension (which corresponds to image size) was too large to fit into GPU memory.

Please try again with a new version and different export settings. If the error persists, reach out and we will be happy to help debug.


I checked your project out on Roboflow Universe and it looks like you already have one trained model. Have the errors come up when you’ve trained with the same image size as that?

only 412 x 412 pixel images were trained sir. larger than that not worked. I tried 512 , 640 sizes but all failed.

It seems like the issues you are experiencing are related to image sizes, especially if training is working on 412, but not 512 or 640.

Have you tried custom training your model through one of our notebooks?

There’s many options, but YOLOv8 should work for your use case. You can freely experiment with epochs, image sizes and batch sizes.

Lowering batch sizes and smaller image sizes can help when there’s an issue with memory.

I tried custom-training my model and it worked. But I wanted to run in the Roboflow environment.

If your custom training worked, you can then upload your trained model to Roboflow and deploy it.

Once it’s uploaded, you’ll have access to all the features of Roboflow Deploy that you’d get from training directly on Roboflow, including a hosted API.

wow it is great sir. I tried ultralytics hub export button. it is not still worked. I will try this… IF you can please send more details or video link to find out how to deplay a model in roboflow after custem training.

You can upload weights to Roboflow using the Roboflow SDK on Python. It depends on what notebook you’re using, so if you’d like more specific guidance I need to know what you’re attempting this on and where you are in the process.

For most notebooks, it’ll look like this (ex: YOLOv8 notebook):

project.version(dataset.version).deploy(model_type="yolov8", model_path=f"{HOME}/runs/detect/train/")

Here are some more resources:

Thank you so much sir.

1 Like