Generating download version is dropping classes and data

When I download the data using YOLO format, instead of 100k images, it’s downloading only 12k images.
I think it’s dropping all the classes except for 1.

I saw a lot of questions about it and you usually tell people to change the class names of their projects. it’s not my dataset so I can’t do it, but I really need to download that data.

any idea how to solve it?


I’m sorry, but your question seems incomplete. You’ve mentioned that your project type is “Object Detection” and you’ve mentioned “Operating System”, but you haven’t asked a specific question. Could you please provide more details or clarify your question? This will help me provide the most accurate and helpful response.

Hi! I’m Roboflow’s AI powered bot. This is an automated response powered using AI with knowledge from our docs, blog, knowledge base, and previous forum responses. If you find this to be a helpful answer, please mark it as the solution using the checkbox icon below. If this doesn’t solve your issue, please follow up with what you’ve tried/why, and the community will continue to chime in as usual.

I have tried to download it in different formats, and I got the same problem.

Hi @Roy_Amoyal

It looks like from the dataset you linked, the author of the dataset has dropped 13 classes (which is probably all except the one you mentioned) from the generated version.

Hey, thanks. @stellasphere
So how does it affect my download? I can clearly see images with other classes annotations in the dataset on the web.

Is there any other way to download all the data including the “dropped” classes?

Hi @Roy_Amoyal

You can clone the images (and annotations) from Universe:

Hey @leo, the method works, but I can’t clone more than 1000 images (even if I clone 200-200 every time), so it doesn’t solve my problem. any idea how to clone in total more than 1000 images? (I know that the limit for free users is 10k images for the project and not only 1k.)

The error:


Hi @Roy_Amoyal

I looked into your account, and it looks like you are on our Sandbox plan which has 1k image limits, but allows private projects. Would you like me to switch you to our public plan (which would make your projects public)?

Yeah, I would like that, thanks!

Hi @Roy_Amoyal

Done! Let me know if there’s any more issues I can help you with.


Looks like it’s still impossible to clone 1000 or more images in the same time:

I can only clone 800 images every time and not all the images in the same time. (I am not sure about the exact number, its probably between 800-999, but I couldn’t clone 1000 images for example)

For now, I will clone 800 images every clone as a workaround.

can you check it on your side? maybe it is a bug?

Hi @Roy_Amoyal

I’m not sure, but I’ll look into it. In the meantime, if you’re trying to clone an entire dataset, it might be better to download a version of that dataset and upload it to your project. (It’s worth noting that this will download with any augmentations that the version is applied with, which might mess up your dataset)