# Roboflow docker for jetson not support my model

**URL:** <https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240>\
**Category:** 🤝  Community Help\
**Tags:** bugs, formats, convert\
**Created:** [April 11, 2024, 3:27am UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240 "2024-04-11T03:27:12Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![louis](https://yyz1.discourse-cdn.com/flex029/user_avatar/discuss.roboflow.com/louis/32/4246_2.png) [@louis](https://discuss.roboflow.com/u/louis)\
**Post date:** [April 11, 2024, 3:27am UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/1 "2024-04-11T03:27:12Z")

</div>

i have problem at my model

i use docker image roboflow/roboflow-inference-server-jetson-4.6.1:latest in my jetson nano board

it work well before i try new model

it work well at version 2 (train at feb )  
but it work not well at version3 (train at apr )

is there have option for this at training

## following is error log at docker run

Traceback (most recent call last):  
File “/app/inference/core/models/roboflow.py”, line 701, in initialize\_model  
self.onnx\_session = onnxruntime.InferenceSession(  
File “/usr/local/lib/python3.9/site-packages/onnxruntime/capi/onnxruntime\_inference\_collection.py”, line 335, in **init**  
self.\_create\_inference\_session(providers, provider\_options, disabled\_optimizers)  
File “/usr/local/lib/python3.9/site-packages/onnxruntime/capi/onnxruntime\_inference\_collection.py”, line 370, in \_create\_inference\_session  
sess = C.InferenceSession(session\_options, self.\_model\_path, True, self.\_read\_config\_from\_model)  
onnxruntime.capi.onnxruntime\_pybind11\_state.Fail: [ONNXRuntimeError] : 1 : FAIL : Load model from /tmp/cache/scanall/3/weights.onnx failed:/home/onnxruntime/onnxruntime/onnxruntime/core/graph/model\_load\_utils.h:57 void onnxruntime::model\_load\_utils::ValidateOpsetForDomain(const std::unordered\_map\<std::\_\_cxx11::basic\_string, int\>&, const onnxruntime::logging::Logger&, bool, const string&, int) ONNX Runtime only _guarantees_ support for models stamped with official released onnx opset versions. Opset 17 is under development and support for this is limited. The operator schemas and or other functionality may change before next ONNX release and in this case ONNX Runtime will not guarantee backward compatibility. Current official support for domain ai.onnx is till opset 16.

The above exception was the direct cause of the following exception:

Traceback (most recent call last):  
File “/app/inference/core/interfaces/http/http\_api.py”, line 163, in wrapped\_route  
return await route(\*args, \*\*kwargs)  
File “/app/inference/core/interfaces/http/http\_api.py”, line 1408, in legacy\_infer\_from\_request  
self.model\_manager.add\_model(  
File “/app/inference/core/managers/decorators/fixed\_size\_cache.py”, line 61, in add\_model  
raise error  
File “/app/inference/core/managers/decorators/fixed\_size\_cache.py”, line 55, in add\_model  
return super().add\_model(model\_id, api\_key, model\_id\_alias=model\_id\_alias)  
File “/app/inference/core/managers/decorators/base.py”, line 55, in add\_model  
self.model\_manager.add\_model(model\_id, api\_key, model\_id\_alias=model\_id\_alias)  
File “/app/inference/core/managers/base.py”, line 60, in add\_model  
model = self.model\_registry.get\_model(resolved\_identifier, api\_key)(  
File “/app/inference/core/models/roboflow.py”, line 607, in **init**  
self.initialize\_model()  
File “/app/inference/core/models/roboflow.py”, line 707, in initialize\_model  
raise ModelArtefactError(  
inference.core.exceptions.ModelArtefactError: Unable to load ONNX session. Cause: [ONNXRuntimeError] : 1 : FAIL : Load model from /tmp/cache/scanall/3/weights.onnx failed:/home/onnxruntime/onnxruntime/onnxruntime/core/graph/model\_load\_utils.h:57 void onnxruntime::model\_load\_utils::ValidateOpsetForDomain(const std::unordered\_map\<std::\_\_cxx11::basic\_string, int\>&, const onnxruntime::logging::Logger&, bool, const string&, int) ONNX Runtime only _guarantees_ support for models stamped with official released onnx opset versions. Opset 17 is under development and support for this is limited. The operator schemas and or other functionality may change before next ONNX release and in this case ONNX Runtime will not guarantee backward compatibility. Current official support for domain ai.onnx is till opset 16.

---

<div class="post-metadata">

**Author:** ![p.peczek](https://yyz1.discourse-cdn.com/flex029/user_avatar/discuss.roboflow.com/p.peczek/32/4168_2.png) [@p.peczek](https://discuss.roboflow.com/u/p.peczek)\
**Post date:** [April 11, 2024, 2:12pm UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/2 "2024-04-11T14:12:04Z")

</div>

> [@louis](#):
>
> it work well at version 2 (train at feb )

Hello there,

Thanks for raising the issue - we had introduced couple of changes into our training process, yet we believed those will be compatible with jetson deployment.

We would be happy to debug the issue, just we need additional context from you:

- what is the digest of docker image you run (`latest` tag shifts from image to image)
- what is the model we are talking about - ideally we would like to know model ids, but if you cannot reveal here - I suggest contact through priv or at least please provide type of the model

---

<div class="post-metadata">

**Author:** ![louis](https://yyz1.discourse-cdn.com/flex029/user_avatar/discuss.roboflow.com/louis/32/4246_2.png) [@louis](https://discuss.roboflow.com/u/louis)\
**Post date:** [April 12, 2024, 12:08am UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/3 "2024-04-12T00:08:58Z")

</div>

Thank you for your reply

- what is the digest of docker image you run (`latest` tag shifts from image to image)  
 → i try two version : latest and test (for 4.6.1)

- what is the model we are talking about - ideally we would like to know model ids, but if you cannot reveal here - I suggest contact through priv or at least please provide type of the model  
scanall/1 , scanall/2 work well  
scanall/3 not work

cardscanall/1 , cardscanall/2 not work

---

<div class="post-metadata">

**Author:** ![p.peczek](https://yyz1.discourse-cdn.com/flex029/user_avatar/discuss.roboflow.com/p.peczek/32/4168_2.png) [@p.peczek](https://discuss.roboflow.com/u/p.peczek)\
**Post date:** [April 12, 2024, 10:35am UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/4 "2024-04-12T10:35:24Z")

</div>

> [@louis](#):
>
> → i try two version : latest and test (for 4.6.1)

> [@louis](#):
>
> → i try two version : latest and test (for 4.6.1)

Ok, but could you please provide the output for:

```auto
docker inspect --format='{{index .RepoDigests 0}}' $IMAGE

```

as I said - `latest` tag drifts over time - I would like to check specific artefact that fails on your end

---

<div class="post-metadata">

**Author:** ![louis](https://yyz1.discourse-cdn.com/flex029/user_avatar/discuss.roboflow.com/louis/32/4246_2.png) [@louis](https://discuss.roboflow.com/u/louis)\
**Post date:** [April 12, 2024, 10:53am UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/5 "2024-04-12T10:53:18Z")

</div>

thank you

here is output

jetson@nano:~/soft$ sudo docker inspect --format=‘{{index .RepoDigests 0}}’ roboflow/roboflow-inference-server-jetson-4.6.1:latest  
roboflow/roboflow-inference-server-jetson-4.6.1@sha256:668f3ebeaa640458f7d9a2e33ba44cf047b51c99f1285abbf8245ce4a7aecfbe

---

<div class="post-metadata">

**Author:** ![p.peczek](https://yyz1.discourse-cdn.com/flex029/user_avatar/discuss.roboflow.com/p.peczek/32/4168_2.png) [@p.peczek](https://discuss.roboflow.com/u/p.peczek)\
**Post date:** [April 12, 2024, 2:50pm UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/6 "2024-04-12T14:50:55Z")

</div>

Ok, verified the problem and seems that the training process changed on our end slightly causing using newer (not supported under jetson 4.x) opset. We will try to fix that and notify once it’s done.

---

<div class="post-metadata">

**Author:** ![louis](https://yyz1.discourse-cdn.com/flex029/user_avatar/discuss.roboflow.com/louis/32/4246_2.png) [@louis](https://discuss.roboflow.com/u/louis)\
**Post date:** [April 22, 2024, 1:56am UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/7 "2024-04-22T01:56:31Z")

</div>

If Docker’s update is delayed, is there an option to learn from a previous version?

---

<div class="post-metadata">

**Author:** ![Jamie\_Shepard](https://yyz1.discourse-cdn.com/flex029/user_avatar/discuss.roboflow.com/jamie_shepard/32/4524_2.png) [@Jamie\_Shepard](https://discuss.roboflow.com/u/Jamie_Shepard)\
**Post date:** [May 8, 2024, 3:30pm UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/8 "2024-05-08T15:30:26Z")

</div>

Does Roboflow support non Docker containers such as Podman, Buildah, runC? Very expensive to scale with Docker

---

<div class="post-metadata">

**Author:** ![system](https://canada1.discourse-cdn.com/flex029/uploads/roboflow1/original/1X/bb6edbfa56d0cf2ee603f061e9e09103502cc8cc.png) [@system](https://discuss.roboflow.com/u/system)\
**Post date:** [May 29, 2024, 3:30pm UTC](https://discuss.roboflow.com/t/roboflow-docker-for-jetson-not-support-my-model/5240/9 "2024-05-29T15:30:59Z")

</div>

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.
